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MITSUBISHI Electric Corporation 

MELSEC A Series  

Ethernet Driver 
 Supported version TOP Design Studio V1.0 or higher  

 

 

CONTENTS 

We would like to thank our customers for using M2I's "Touch 

Operation Panel (M2I TOP) Series". Read this manual and familiarize 

yourself with the connection method and procedures of the “TOP and 

external device”. 

 

 

 

 

1. System configuration Page 2 

 

 

Describes the devices required for connection, the setting of 

each device, cables, and configurable systems. 

2. External device selection  Page 3 

 Select a TOP model and an external device. 

3. TOP communication setting Page 4 

 Describes how to set the TOP communication. 

4. External device setting Page 9 

 Describes how to set up communication for external devices. 

5. Supported addresses Page 11 

 Refer to this section to check the addresses which can 

communicate with an external device. 



 

 External device connection manual for TOP Design Studio 2 / 11 

1. System configuration 

The system configuration of TOP and “MITSUBISHI Electric Corporation - MELSEC A Series Ethernet” is as follows. 

 

Series CPU Link I/F 
Communication 

method 

Communication 

setting 
Cable 

MELSEC-A 

A1N 

A2N 

A0J2H 

AJ71E71 

AJ71E71-S3 

Ethernet 

(TCP/UDP) 

3. TOP 

communication 

setting 

4. External device 

setting 

Twisted pair cable*Note 1) 

A1S 

A1S-C24 

A1SJ 

A2S 

A2S-S1 

A1SJ71E71-B2 

A1SJ71E71-B5 

A1S 

A1SH 

A1SJ 

A2S 

A2SH 

A2SJH 

A1SJ71E71-B2-S3 

A1SJ71E71-B5-S3 

*Note 1) Twisted pair cable 

- Refer to STP (Shielded Twisted Pair Cable) or UTP (Unshielded Twisted Pair Cable) Category 3, 4, 5. 

- Depending on the network configuration, you can connect to components such as the hub and transceiver, and in this case, use a 

direct cable. 

 

 

■ Connectable configuration 

 

ㆍ1:1 connection (one TOP and one external device) connection 

 

 

ㆍ1:N connection (one TOP and multiple external devices) connection 
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2. External device selection 

■ Select a TOP model and a port, and then select an external device. 
 

 

 
 

 
 

 

Settings Contents 

TOP Model Check the TOP display and process to select the touch model. 

External device Vendor Select the vendor of the external device to be connected to TOP. 

Please select “MITSUBISHI Electric Corporation”. 

PLC Select the external device to be connected to the TOP. 
 

Model Interface Protocol 

MELSEC A Series Ethernet MC Protocol 1E Binary 
 

Please check the system configuration in Chapter 1 to see if the external device you want to 

connect is a model whose system can be configured. 

Supported Protocol 

MC Protocol 1E (BINARY) 
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3. TOP communication setting 

The communication can be set in TOP Design Studio or TOP main menu. The communication should be set in the same way as that 

of the external device. 
 

3.1 Communication setting in TOP Design Studio 

(1) Communication interface setting 

■ [ Project > Project properties > TOP settings] → [Project option > Check “Use HMI settings” > Edit > Ethernet ] 

– Set the TOP communication interface in TOP Design Studio. 
 

 

 

 

 
 

Items TOP External device Remarks 

IP Address*Note 1) Note 2) 192.168.0.50 192.168.0.51  

Subnet Mask 255.255.255.0 255.255.255.0  

Gateway 192.168.0.1 192.168.0.1  

*Note 1) The network addresses of the TOP and the external device (the first three digits of the IP, 192 . 168 . 0 . 0) should match. 

*Note 2) Do not use duplicate IP addresses over the same network. 

* The above settings are examples recommended by the company. 

 

 

Items Description 

IP Address Set an IP address to be used by the TOP to use over the network. 

Subnet Mask Enter the subnet mask of the network. 

Gateway Enter the gateway of the network. 
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(2) Communication option setting 

■ [ Project > Project properties > PLC setting > ETHERNET > “PLC1 : MELSEC-A Series”] 

– Set the options of the communication driver of MELSEC A Series Ethernet in TOP Design Studio. 

 

 

Items Settings Remarks 

Interface Select “Ethernet”. Refer to “2. External 

device selection”. Protocol Select “MC Protocol 1E Binary”. 

IP Enter the IP address of the external device.  

Ethernet Protocol Select the Ethernet protocol between the TOP and an external device.  

Port Enter the Ethernet communication port number of an external device.  

TimeOut (ms) Set the time for the TOP to wait for a response from an external device.  

SendWait (ms) Set the waiting time between TOP’s receiving a response from an external device 

and sending the next command request. 
 

PC No Set the prefix of TOP.  
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3.2. Communication setting in TOP  

* This is a setting method when “Use HMI Setup” in the setting items in “3.1 TOP Design Studio” is not checked. 
 

■ Touch the top of the TOP screen and drag it down. Touch “EXIT” in the pop-up window to go to the main screen.  

   

(1) Communication interface setting 

■ [ Main screen > Control panel > Ethernet ] 
 

 

 

Items TOP External device Remarks 

IP Address*Note 1) Note 2) 192.168.0.50 192.168.0.51  

Subnet Mask 255.255.255.0 255.255.255.0  

Gateway 192.168.0.1 192.168.0.1  

*Note 1) The network addresses of the TOP and the external device (the first three digits of the IP, 192 . 168 . 0 . 0) should match. 

*Note 2) Do not use duplicate IP addresses over the same network. 

* The above settings are examples recommended by the company. 

 

 

Items Description 

IP Address Set an IP address to be used by the TOP to use over the network. 

Subnet Mask Enter the subnet mask of the network. 

Gateway Enter the gateway of the network. 
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 (2) Communication option setting 

■ [ Main screen > Control panel > PLC ] 
 

 

 

Items Settings Remarks 

Interface Select “Ethernet”. Refer to “2. External 

device selection”. Protocol Select “MC Protocol 1E Binary”. 

IP Enter the IP address of the external device.  

Ethernet Protocol Select the Ethernet protocol between the TOP and an external device.  

Port Enter the Ethernet communication port number of an external device.  

TimeOut (ms) Set the time for the TOP to wait for a response from an external device.  

SendWait (ms) Set the waiting time between TOP’s receiving a response from an external device and 

sending the next command request. 
 

PC No Set the prefix of TOP.  

 

 

  



 

 External device connection manual for TOP Design Studio 8 / 11 

3.3 Communication diagnostics 

■ Check the interface setting status between the TOP and an external device. 

- Touch the top of the TOP screen and drag it down. Touch “EXIT” in the pop-up window to go to the main screen. 

- Check whether the port (ETH1/ETH2) settings you want to use are the same as those of the external device in [Control panel > 

Ethernet]. 

 

■ Diagnosis of whether the port communication is normal or not 

- Touch “Communication diagnostics” in [Control Panel > PLC ]. 

- The Diagnostics dialog box pops up on the screen and determines the diagnostic status. 

OK Communication setting normal 

Time Out Error Communication setting abnormal 

- Check the cable, TOP, and external device setting status. (Reference: Communication diagnostics sheet) 

 

■ Communication diagnostics sheet 

- If there is a problem with the communication connection with an external terminal, please check the settings in the sheet below. 

Item Content Confirm Remarks 

System 

configuration 

How to connect the system OK NG 
1. System configuration 

Connection cable name OK NG 

TOP Version information OK NG 

2. External device selection 

3. Communication setting 

Port in use OK NG 

Driver name OK NG 

Other detailed settings OK NG 

Relative prefix Project setting OK NG 

Communication 

diagnostics 
OK NG 

Ethernet port setting IP Address OK NG 

Subnet Mask OK NG 

Gateway OK NG 

External device CPU name OK NG 

4. External device setting 

Communication port name (module name) OK NG 

Protocol (mode) OK NG 

Setup Prefix OK NG 

Other detailed settings OK NG 

Ethernet port setting IP Address OK NG 

Subnet Mask OK NG 

Gateway OK NG 

Check address range  

OK NG 

5. Supported addresses 

(For details, please refer to the PLC 

vendor's manual.) 
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4. External device setting 

In order to set up the communication settings of the MELSEC-A Series Ethernet communication module, configure the Ladder 

Software and DIP Switch inside the device as shown below. For a more detailed setting method than that described in this example, 

refer to the PLC user manual 
 

 
Do not use duplicate IP addresses over the same network. 

 

Step 1. Write the sequence program shown in the example below and download it as PLC. 

(The following example depicts the Ethernet reset program for when the Ethernet card is installed in slot 0. If the Ethernet card’s slot 

position changes, the addresses for X and Y shown in the example above must also change. For example, if a card takes up 32 

points in slot 0 and an Ethernet card is installed in slot 1, the X1F used in the line 0 of the above example becomes X3F (+32 points). 

The H0 (buffer memory start address) of TO and FROM commands is converted to H2 (32 points = 2 words).) 

 
 

Buffer memory settings Custom device 

Address Settings Setting (range) Address Settings 

0~1 Ethernet card IP address C0A80033H (192.168.0.51) M102 COM.ERR OFF command 

16 Intended use settings 100H (fixed) D100 Ethernet card IP address 

24 Ethernet card port number 5001 D110 Intended use settings 

25~26 Counterpart device (TOP) IP address FFFFFFFFH (fixed) D111 Ethernet card port number 

27 Counterpart device (TOP) port 

number 

FFFFH (fixed) D112 

~D113 

Counterpart device (TOP) IP Address 

80 Reset error code - D114 Counterpart device (TOP) port number 

 D200 Reset error code 

Ethernet module reset process 

After RUN 

scan once 

Ethernet module 

IP address 

Open processing of communication line 

COM.ERR 

OFF 

command 

ONWDT ERR 

detected 

WDT ERR 

detected 

Faulty reset 

detected 

Open 

complete 

No.1 

Reset 

complete 

Reset request 

Read faulty 

reset code 

COM.ERR  

OFF request 

Clear faulty 

reset code 

Permit contact 

when PLC CPU is 

stopped 

Communication 

method UDP 

Ethernet module 

port number 

Open request 

Reset request 
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Step 2. Configure the Dip Switch settings for the entire module, once sequence program transmission is completed. 

(1) Operation Mode Switch 

Operation Mode Switch Contents Setting Value 

 

Online 0 (fixed) 

 

(2) Conditional Contact Switch 

◆ Configure the AJ71E71 / AJ71E71-S3 as shown in the table below. 

Conditional Contact Switch DIP Switch Contents Setting Value 

 

SW1 Line processing for TCP timeout error OFF 

SW2 
Data code settings 

(Binary code) 
OFF 

SW3 

Not used 

OFF 

SW4 OFF 

SW5 OFF 

SW6 OFF 

SW7 
CPU contact timing settings 

(Permit WRITE during RUN) 
ON 

SW8 Reset time settings OFF 

 

◆ Configure the A1SJ71E71-B2 / A1SJ71E71-B5 / A1SJ71E71-B2-S3 / A1SJ71E71-B2 –S3 as shown in the table below. 

Conditional Contact Switch DIP Switch Contents Setting Value 

 

SW1 Line processing for TCP timeout error OFF 

SW2 
Data code settings 

(Binary code) 
OFF 

SW3 
CPU contact timing settings 

(Permit WRITE during RUN) 
ON 

SW4 Reset time settings OFF 

Step 3. Restart the power after configuring the Dip Switch. 
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5. Supported addresses 

The devices available in TOP are as follows:  

The device range (address) may differ depending on the CPU module series/type. The TOP series supports the maximum address 

range used by the external device series. Please refer to each CPU module user manual and be take caution to not deviate from the 

address range supported by the device you want to use. 

 

Type Remarks Bit-designated address Word-designated address 

Input Bit X0000 - X07FF X0000 - X07F0 

Output Bit Y0000 - Y07FF Y0000 - Y07F0 

LINK relay Bit B0000 - B03FF  

LINK register Word  W0000 - W03F0 

Special relay Bit F0000 - F0255 F0000 - F0240 

LATCH relay Bit L0000 - L2047 L0000 - L2032 

Internal relay Bit M0000 - M2047 M0000 - M2032 

Special relay Bit M9000 - M9255 M9000 - M9240 

Timer - Coil Bit TC000 - TC255  

Timer - Contact Bit TS000 - TS255  

Timer-Current value Word  TN000 - TN255 

Counter - Coil Bit CC000 - CC255  

Counter - Contact Bit CS000 - CS255  

Counter-Current value Word  CN000 - CN255 

Data register Word D0000.0 – D1023.15 D0000 - D1023 

File register Word R0000.0 – R8191.15 R0000 – R8191 

 

 


